Monitoring and reporting for Veeam Data Platform
Post Reply
mcvosi
Enthusiast
Posts: 65
Liked: 8 times
Joined: Jun 14, 2011 1:55 pm
Full Name: Matthew Vaughan
Contact:

Failed to detect Veeam Backup & Replication Server

Post by mcvosi »

Just upgraded B&R to 12. Last week I upgraded VONE to 12. VONE server will not see the B&R server. Tried removing and adding, but says it cannot detect it's installed on that server.
RomanK
Veeam Software
Posts: 632
Liked: 167 times
Joined: Nov 01, 2016 11:26 am
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by RomanK »

Hello Matthew,

Please open a support case and provide the case ID in this thread so we could collect all the additional details and investigate it accordingly.

Thanks
mcvosi
Enthusiast
Posts: 65
Liked: 8 times
Joined: Jun 14, 2011 1:55 pm
Full Name: Matthew Vaughan
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by mcvosi »

Done.

Case ID 02698231.
RomanK
Veeam Software
Posts: 632
Liked: 167 times
Joined: Nov 01, 2016 11:26 am
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by RomanK »

Hello Matthew,

I see no case with this ID in our system. Could you please double-check it?

Thanks
jorgedlcruz
Veeam Software
Posts: 1358
Liked: 613 times
Joined: Jul 17, 2015 6:54 pm
Full Name: Jorge de la Cruz
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by jorgedlcruz »

Hello Matthew,
I was wondering if you managed to open the support case and if you could share the number with us? It should start with 07

Thanks!
Jorge de la Cruz
Senior Product Manager | Veeam ONE @ Veeam Software

@jorgedlcruz
https://www.jorgedelacruz.es / https://jorgedelacruz.uk
vExpert 2014-2024 / InfluxAce / Grafana Champion
tommy.oshea
Service Provider
Posts: 6
Liked: 1 time
Joined: Dec 01, 2021 1:52 pm
Full Name: Tommy O'Shea
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by tommy.oshea »

Hello,

I'm having the same issue. I've opened up case number 07002737 for this and uploaded logs.
I haven't gone as far as to remove and re-add the server from the client, as that will mess up far too many configured scheduled reports.
jorgedlcruz
Veeam Software
Posts: 1358
Liked: 613 times
Joined: Jul 17, 2015 6:54 pm
Full Name: Jorge de la Cruz
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by jorgedlcruz »

Thank you Tommy,
Let's see if Support can see anything in the logs. Thanks for the support case
Jorge de la Cruz
Senior Product Manager | Veeam ONE @ Veeam Software

@jorgedlcruz
https://www.jorgedelacruz.es / https://jorgedelacruz.uk
vExpert 2014-2024 / InfluxAce / Grafana Champion
_james
Enthusiast
Posts: 30
Liked: 6 times
Joined: Nov 15, 2018 3:51 pm
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by _james » 1 person likes this post

Hello everyone, @tommy.oshea did you manage to resolve this issue?

Having same problem with the new v12 BR and One server. Are there any new communication requirements between Veeam One?
RomanK
Veeam Software
Posts: 632
Liked: 167 times
Joined: Nov 01, 2016 11:26 am
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by RomanK »

Hello _james,

Case 07002737 is closed by the creator. Unfortunately, there is no additional information, no hotfixes were applied by support. I'd suggest opening a separate case instead.

Thanks
prolix21
Influencer
Posts: 10
Liked: 1 time
Joined: Mar 15, 2010 3:06 pm
Full Name: dan
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by prolix21 » 1 person likes this post

Having the same issue - will be opening a case I guess. Veeam One v12 can communicate with our other Veeam B&R systems just fine (v10 and v11) but the v12 B&R server it won't even connect to. Even tired a completely clean Veeam One v12 install.
RomanK
Veeam Software
Posts: 632
Liked: 167 times
Joined: Nov 01, 2016 11:26 am
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by RomanK »

Hello Dan,

Correct, guessing the cause of the problem on the forum is not the best way to troubleshoot.

Having case # in the thread helps us to check the current state, root cause, and applied fixes. Please do not forget to provide the case ID.

Thanks
_james
Enthusiast
Posts: 30
Liked: 6 times
Joined: Nov 15, 2018 3:51 pm
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by _james »

Hello @prolix21, sorry for the late response, but for us the Veeam WMI libraries on the Veeam BR server was causing the issue, once reinstalled the communication resumed.
ibarizz
Enthusiast
Posts: 46
Liked: 5 times
Joined: Jul 28, 2021 2:36 pm
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by ibarizz »

Hello,

I had this issue with a few Veeam 12 deployments, every time by reinstalling the Veeam.Backup.WmiServer.exe it solved the issue.
However, in the case you have your Veeam ONE server on the same server as Veeam B&R, I coudn't manage to solve it. In that case, does somebody have an idea how to solve this?
Thank you in advance!
DidUBackup1st
Veeam Software
Posts: 1
Liked: never
Joined: Jul 19, 2022 1:50 pm
Full Name: Christian Avian
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by DidUBackup1st »

Hello,

This issue can occur for multiple reasons. Most notably a network connectivity issue or permission issues with the account being used to make the connection. To troubleshoot this issue, I recommend verifying that the account you are using to make the connection has the required permissions added to it. The permissions need to be added explicitly for the account being used to make the connection following the steps found here: https://helpcenter.veeam.com/docs/one/d ... ml?ver=120

Additionally, the Veeam One server will need to be able to communicate with the Veeam Backup and Replication server using WMI. This requires port 135 and the dynamic port range 49152 to 65535 are opened between the two servers.

Lastly, the account being used to connect to the Veeam Backup and Replication server will need to have the role "Backup Administrator" added to it in the Veeam Backup and Replication console to allow the connection to be made. The steps to add the account to that role can be found here: https://helpcenter.veeam.com/docs/backu ... ml?ver=120


For troubleshooting quickly to see what your issue might be related to, here is a powershell script you can use to test the connection to the Veeam Backup and Replication server. Please note that credentials can only be used when the connection is made remotely. If the Veeam Backup and Replication server is on the same server as the Veeam One server, you would have to remove the credentials switch from this script and you would just need to be logged in as the account you are using to make the connection.

Powershell for tests to remote machines:

Code: Select all

Get-WmiObject -Namespace "root\VeeamBS" -Class "BackupServer" -Impersonation 3 -Authentication 6 -ComputerName "Enter the VBR hostname here" -Credential ` "domain\username" | select *
Powershell for tests for local machines (ensure you are logged in with the account you are using to make the connection):

Code: Select all

Get-WMIObject -Namespace "root\VeeamBS" -Query "SELECT * FROM BackupServer"
A successful run of this script should output information about the Veeam Backup and Replication server. If the connection fails with an RPC server unavailable, it's likely that there is a network related issue preventing the connection. Ensure your firewall and network settings allow for the connection: https://helpcenter.veeam.com/docs/one/d ... ml?ver=120

If you receive an access denied error, then the issue is likely related to the permissions on the account performing the test (see above recommendations). Additionally, if you still have access denied issues after applying all of the required permissions, ensure that the Veeam One and Veeam Backup and Replication server have all applicable Microsoft updates run on them as there were changes to dcom over the years that can cause "permission" issues. 


As always if you tried everything here, please put in a support case with Veeam for further troubleshooting!
sandpiper331
Lurker
Posts: 1
Liked: never
Joined: Oct 06, 2023 9:25 pm
Full Name: Andrew Morris
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by sandpiper331 »

I am having this exact same problem. Once I upgraded VBR to v12 it stopped communicating with VeeamOne. How do you reinstall the Veeam WMI libraries or Veeam.Backup.WmiServer.exe without uninstalling and reinstalling everything? I do see any individual installers for this and there is no repair install option on VBR either. Veeam support had me completely reinstall the Disaster Recovery Orchestrator from scratch, along with VeeamOne, to fix this issue and it did not fix anything. I do not want to have to go through that again with VBR.
jorgedlcruz
Veeam Software
Posts: 1358
Liked: 613 times
Joined: Jul 17, 2015 6:54 pm
Full Name: Jorge de la Cruz
Contact:

Re: Failed to detect Veeam Backup & Replication Server

Post by jorgedlcruz » 1 person likes this post

Hello Andrew,
Have you tried opening a support case? If so, please let us know the case number.

Thank you
Jorge de la Cruz
Senior Product Manager | Veeam ONE @ Veeam Software

@jorgedlcruz
https://www.jorgedelacruz.es / https://jorgedelacruz.uk
vExpert 2014-2024 / InfluxAce / Grafana Champion
Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests