Discussions specific to the VMware vSphere hypervisor
Post Reply
ferrus
Veeam ProPartner
Posts: 184
Liked: 23 times
Joined: Dec 03, 2015 3:41 pm
Location: UK
Contact:

v9.5 update 1 - NFS issue

Post by ferrus » Mar 27, 2017 1:59 pm

I patched our v9.5 Veeam servers last week, with update 1.
Most thing went smoothly, but there's one outstanding issue I've noticed - that appears to have been caused by the update.

Our VMware vmkernel network is on a different subnet from the ESX servers and Veeam servers, so to create the NFS connections between VMware and Veeam - I had to set up static NFS mappings in vCenter and registry entries on the Veeam servers.

Since the update, the NFS export remains on the main Veeam B&R server - but the three proxy servers have had their registry keys wiped, and the static NFS mappings left 'inactive'.

I'll can recreate them again, but just wondering if anyone else experienced the same issue upgrading?

ferrus
Veeam ProPartner
Posts: 184
Liked: 23 times
Joined: Dec 03, 2015 3:41 pm
Location: UK
Contact:

Re: v9.5 update 1 - NFS issue

Post by ferrus » Mar 27, 2017 2:08 pm

specifically the registry key here (but only on the proxy servers):

vmware-vsphere-f24/how-to-use-veeam-vpo ... ml#p177009

Code: Select all

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Veeam\Veeam NFS\Shared Folders\{GUID}

"nfsFolderName"="/VeeamBackup_FQDN OF YOUR BACKUP SERVER" (STRING TYPE)

ferrus
Veeam ProPartner
Posts: 184
Liked: 23 times
Joined: Dec 03, 2015 3:41 pm
Location: UK
Contact:

[MERGED] Bug Report: vPower NFS export

Post by ferrus » Aug 01, 2017 10:22 am

Posted this after upgrading to 9.5 Update 1 - but it's either unique to our infrastructure only, or too few people have manual NFS mount points to confirm the issue.

vmware-vsphere-f24/v9-5-update-1-nfs-issue-t41961.html

I've recently installed 9.5 Update 2, and the same issue occured:

The static NFS mount point on the main B&R server is retained
The static NFS mount points on all the proxy/repo servers are wiped, during the upgrade

Location:

Code: Select all

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Veeam\Veeam NFS\Shared Folders\{GUID}

"nfsFolderName"="/VeeamBackup_FQDN OF YOUR BACKUP SERVER" (STRING TYPE)
Could this be confirmed, and resolved for U3/Veeam 10?
Takes a while to set everything back up!

foggy
Veeam Software
Posts: 16702
Liked: 1343 times
Joined: Jul 11, 2011 10:22 am
Full Name: Alexander Fogelson
Contact:

Re: v9.5 update 1 - NFS issue

Post by foggy » Aug 03, 2017 4:45 pm

Confirmed, vPowerNFS installation package overwrites registry value. Cannot comment on when it is to be addressed though.

wooying
Lurker
Posts: 1
Liked: never
Joined: Sep 28, 2011 12:15 pm
Full Name: Woo Ying
Contact:

[MERGED] Veeam vPower NFS Service fails to start after updat

Post by wooying » Jun 02, 2018 3:47 pm

This all start when I tried to upgrade Veeam 9.5 update 3, after the upgrade I cannot get the upgrade to start off any jobs as well as start the service Implements vPower NFS server. When I start Backup & Replication it tell me vPower NFS need to upgrade, but since the service won't start I think that is why it would allow me to upgrade. All jobs are failing can anyone offer me any assistance? I have a case number #03036067 . TIA

PTide
Veeam Software
Posts: 4248
Liked: 350 times
Joined: May 19, 2015 1:46 pm
Contact:

Re: v9.5 update 1 - NFS issue

Post by PTide » Jun 04, 2018 2:04 pm

Hi,

As far as I can see from your case, the issue has been resolved via means described in this KB article, is that correct?

Thanks

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 29 guests