Discussions specific to the VMware vSphere hypervisor
Post Reply
randy16randy
Novice
Posts: 9
Liked: never
Joined: Mar 20, 2012 6:28 pm
Full Name: Randy Redekopp
Contact:

VM Restore Fails after vCenter Replaced

Post by randy16randy » Sep 06, 2018 3:54 pm

We recently changed from vCenter server 5.5 on Windows server to v6.0 appliance.
I recreated the backup job using the new vCenter as the source for adding the VMs.
I performed a test restore of a client VM but it fails as it tries to connect to the IP address of the old vCenter

Error: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.2.27:443

I powered up the old vCenter, even though everything has been removed from its inventory, and tried again. Now the message is:

Error: No connection could be made because the target machine actively refused it 192.168.2.27:443

I must have missed something but only articles I find are all about restoring vCenter itself or restoring a VM when vCenter is dead.
I don't have a case ID yet as I thought I'd try the community first.

MichaelCade
Veeam Software
Posts: 250
Liked: 48 times
Joined: Mar 23, 2015 11:55 am
Full Name: Michael Cade
Location: Cambridge, United Kingdom
Contact:

Re: VM Restore Fails after vCenter Replaced

Post by MichaelCade » Sep 06, 2018 4:14 pm

When you run through the restore wizard if you are picking a restore point that was taken whilst the previous 5.5 VC was in play then it would think this is the original location, you would i would expect then have to restore to a different location and choose your new appliance.

This is the wizard for instant VM recovery where this can be configured.

Image

Similar for Full VM restore

Image

Hope that helps.
Regards,

Michael Cade
Global Technologist
Veeam Software
Email: Michael.Cade@Veeam.com
Twitter: @MichaelCade1

bdufour
Expert
Posts: 165
Liked: 26 times
Joined: Nov 01, 2017 8:52 pm
Full Name: blake dufour
Contact:

Re: VM Restore Fails after vCenter Replaced

Post by bdufour » Sep 06, 2018 4:15 pm

it seems as though the restore point you chose would have been tied to the old vcenter server - could have been an older restore point created through the old vcenter.

randy16randy
Novice
Posts: 9
Liked: never
Joined: Mar 20, 2012 6:28 pm
Full Name: Randy Redekopp
Contact:

Re: VM Restore Fails after vCenter Replaced

Post by randy16randy » Sep 06, 2018 5:34 pm

Thanks MichaelCade.
I had thought it wouldn't matter as I picked a new Full backup assuming that should be clean of previous associations, however your suggestion worked fine and I was able to complete a test restore using the Full Restore Wizard.

MichaelCade
Veeam Software
Posts: 250
Liked: 48 times
Joined: Mar 23, 2015 11:55 am
Full Name: Michael Cade
Location: Cambridge, United Kingdom
Contact:

Re: VM Restore Fails after vCenter Replaced

Post by MichaelCade » Sep 06, 2018 5:36 pm

Good stuff thanks for letting me know.
Regards,

Michael Cade
Global Technologist
Veeam Software
Email: Michael.Cade@Veeam.com
Twitter: @MichaelCade1

Post Reply

Who is online

Users browsing this forum: No registered users and 25 guests